re = /^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\w ,.-]+$/mi
str = 'this should match
and this too
Test Po Box - Should NOT be acceptable
Test Post Office Box - Should NOT be acceptable
Test Po,Box - Should NOT be acceptable
Test PO BOx - Should NOT be acceptable
Test-123po - Should be acceptable
Test-!@$% - Should NOT be acceptable
Test123@#$ PoBOX - Should NOT be acceptable.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end