use strict;
my $str = 'this should match
and this too
Test Po Box - Should NOT be acceptable
Test Post Office Box - Should NOT be acceptable
Test Po,Box - Should NOT be acceptable
Test PO BOx - Should NOT be acceptable
Test-123po - Should be acceptable
Test-!@$% - Should NOT be acceptable
Test123@#$ PoBOX - Should NOT be acceptable.';
my $regex = qr/^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\w ,.-]+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}