import re
regex = re.compile(r"^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\w ,.-]+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("this should match\n"
"and this too\n\n"
"Test Po Box - Should NOT be acceptable\n"
"Test Post Office Box - Should NOT be acceptable\n"
"Test Po,Box - Should NOT be acceptable\n"
"Test PO BOx - Should NOT be acceptable\n"
"Test-123po - Should be acceptable\n"
"Test-!@$% - Should NOT be acceptable\n"
"Test123@#$ PoBOX - Should NOT be acceptable.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")