# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\d\.\n]+//gm;t' <<< "fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165"