re = /[^\d\.\n]+/m
str = 'fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result