using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\d\.\n]+";
string substitution = @"";
string input = @"fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}