const regex = /[^\d\.\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d\\.\\n]+', 'gm')
const str = `fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);