import Foundation
let pattern = #"[^\d\.\n]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)