#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bLUA\b"
Local $sString = "LUA" & @CRLF & _
"lua" & @CRLF & _
"I eat LUA" & @CRLF & _
"I ate LUAU" & @CRLF & _
"I used lua" & @CRLF & _
"I used LUA today" & @CRLF & _
"I used LUAU today" & @CRLF & _
"I used lua today" & @CRLF & _
"lua says hello" & @CRLF & _
"LUA says hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")