// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bLUA\b").unwrap();
let string = "LUA
lua
I eat LUA
I ate LUAU
I used lua
I used LUA today
I used LUAU today
I used lua today
lua says hello
LUA says hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}