import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bLUA\\b";
final String string = "LUA\n"
+ "lua\n"
+ "I eat LUA\n"
+ "I ate LUAU\n"
+ "I used lua\n"
+ "I used LUA today\n"
+ "I used LUAU today\n"
+ "I used lua today\n"
+ "lua says hello\n"
+ "LUA says hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}