$re = '/\bLUA\b/m';
$str = 'LUA
lua
I eat LUA
I ate LUAU
I used lua
I used LUA today
I used LUAU today
I used lua today
lua says hello
LUA says hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);