re = /\bLUA\b/m
str = 'LUA
lua
I eat LUA
I ate LUAU
I used lua
I used LUA today
I used LUAU today
I used lua today
lua says hello
LUA says hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end