import re
regex = re.compile(r"\bLUA\b", flags=re.MULTILINE)
test_str = ("LUA\n"
"lua\n"
"I eat LUA\n"
"I ate LUAU\n"
"I used lua\n"
"I used LUA today\n"
"I used LUAU today\n"
"I used lua today\n"
"lua says hello\n"
"LUA says hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")