# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\W\d_])(\d)/\1 \2/gmu;t' <<< "سعید123"