$re = '/([^\W\d_])(\d)/mu';
$str = 'سعید123';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;