import re
regex = re.compile(r"([^\W\d_])(\d)", flags=re.MULTILINE | re.UNICODE)
test_str = "سعید123"
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)