package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\W\d_])(\d)`)
var str = `سعید123`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}