using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:blank:]]";
string input = @"ALL_CHARS:
SPACES :
tab{ }
space{ }
nobreakspace{ }
narrownobreakspace{ }
enquad{ }
emquad{ }
enspace{ }
emspace{ }
threeperemspace{ }
fourperemspace{ }
sixperemspace{ }
figurespace{ }
punctuationspace{ }
breakablethinspace{ }
hairspace{ }
ZERO-WIDTH SPACES :
zerowidthspace{}
zerowidthnobreakspace{}
JOINERS :
wordjoiner{}
zerowidthnonjoiner{}
zerowidthjoiner{}
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}