import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[[:blank:]]";
final String string = "ALL_CHARS:\n\n"
+ "SPACES :\n"
+ "tab{ }\n"
+ "space{ }\n"
+ "nobreakspace{ }\n"
+ "narrownobreakspace{ }\n"
+ "enquad{ }\n"
+ "emquad{ }\n"
+ "enspace{ }\n"
+ "emspace{ }\n"
+ "threeperemspace{ }\n"
+ "fourperemspace{ }\n"
+ "sixperemspace{ }\n"
+ "figurespace{ }\n"
+ "punctuationspace{ }\n"
+ "breakablethinspace{ }\n"
+ "hairspace{ }\n\n"
+ "ZERO-WIDTH SPACES :\n"
+ "zerowidthspace{}\n"
+ "zerowidthnobreakspace{}\n\n"
+ "JOINERS :\n"
+ "wordjoiner{}\n"
+ "zerowidthnonjoiner{}\n"
+ "zerowidthjoiner{}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}