import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[[:blank:]]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ALL_CHARS:
SPACES :
tab{ }
space{ }
nobreakspace{ }
narrownobreakspace{ }
enquad{ }
emquad{ }
enspace{ }
emspace{ }
threeperemspace{ }
fourperemspace{ }
sixperemspace{ }
figurespace{ }
punctuationspace{ }
breakablethinspace{ }
hairspace{ }
ZERO-WIDTH SPACES :
zerowidthspace{}
zerowidthnobreakspace{}
JOINERS :
wordjoiner{}
zerowidthnonjoiner{}
zerowidthjoiner{}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)