const regex = /[[:blank:]]/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[:blank:]]', 'gu')
const str = `ALL_CHARS:
SPACES :
tab{ }
space{ }
nobreakspace{ }
narrownobreakspace{ }
enquad{ }
emquad{ }
enspace{ }
emspace{ }
threeperemspace{ }
fourperemspace{ }
sixperemspace{ }
figurespace{ }
punctuationspace{ }
breakablethinspace{ }
hairspace{ }
ZERO-WIDTH SPACES :
zerowidthspace{}
zerowidthnobreakspace{}
JOINERS :
wordjoiner{}
zerowidthnonjoiner{}
zerowidthjoiner{}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}