# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[[:blank:]]"
test_str = ("ALL_CHARS:\n\n"
"SPACES :\n"
"tab{ }\n"
"space{ }\n"
"nobreakspace{ }\n"
"narrownobreakspace{ }\n"
"enquad{ }\n"
"emquad{ }\n"
"enspace{ }\n"
"emspace{ }\n"
"threeperemspace{ }\n"
"fourperemspace{ }\n"
"sixperemspace{ }\n"
"figurespace{ }\n"
"punctuationspace{ }\n"
"breakablethinspace{ }\n"
"hairspace{ }\n\n"
"ZERO-WIDTH SPACES :\n"
"zerowidthspace{}\n"
"zerowidthnobreakspace{}\n\n"
"JOINERS :\n"
"wordjoiner{}\n"
"zerowidthnonjoiner{}\n"
"zerowidthjoiner{}\n\n")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.