// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[[:blank:]]").unwrap();
let string = "ALL_CHARS:
SPACES :
tab{ }
space{ }
nobreakspace{ }
narrownobreakspace{ }
enquad{ }
emquad{ }
enspace{ }
emspace{ }
threeperemspace{ }
fourperemspace{ }
sixperemspace{ }
figurespace{ }
punctuationspace{ }
breakablethinspace{ }
hairspace{ }
ZERO-WIDTH SPACES :
zerowidthspace{}
zerowidthnobreakspace{}
JOINERS :
wordjoiner{}
zerowidthnonjoiner{}
zerowidthjoiner{}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}