#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<!^kalender) - .* - outlook"
Local $sString = "Kalender - user1@firma.de - outlook" & @CRLF & _
"Kalender - user1@company.com - outlook" & @CRLF & _
"Kalender - user2@company.com - outlook" & @CRLF & _
"Kalender - user3@company.com - outlook" & @CRLF & _
"inbox - user1@company.com - outlook" & @CRLF & _
"inbox - user2@company.com - outlook" & @CRLF & _
"inbox - user3@company.com - outlook" & @CRLF & _
"sent - user1@company.com - outlook" & @CRLF & _
"sent - user2@company.com - outlook" & @CRLF & _
"sent - user3@company.com - outlook" & @CRLF & _
"waiting - user1@company.com - outlook" & @CRLF & _
"waiting - user2@company.com - outlook" & @CRLF & _
"waiting - user3@company.com - outlook"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")