re = /(?<!^kalender) - .* - outlook/mi
str = 'Kalender - user1@firma.de - outlook
Kalender - user1@company.com - outlook
Kalender - user2@company.com - outlook
Kalender - user3@company.com - outlook
inbox - user1@company.com - outlook
inbox - user2@company.com - outlook
inbox - user3@company.com - outlook
sent - user1@company.com - outlook
sent - user2@company.com - outlook
sent - user3@company.com - outlook
waiting - user1@company.com - outlook
waiting - user2@company.com - outlook
waiting - user3@company.com - outlook'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end