# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!^kalender) - .* - outlook"
test_str = ("Kalender - user1@firma.de - outlook\n"
"Kalender - user1@company.com - outlook\n"
"Kalender - user2@company.com - outlook\n"
"Kalender - user3@company.com - outlook\n"
"inbox - user1@company.com - outlook\n"
"inbox - user2@company.com - outlook\n"
"inbox - user3@company.com - outlook\n"
"sent - user1@company.com - outlook\n"
"sent - user2@company.com - outlook\n"
"sent - user3@company.com - outlook\n"
"waiting - user1@company.com - outlook\n"
"waiting - user2@company.com - outlook\n"
"waiting - user3@company.com - outlook")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.