$re = '/(?<!^kalender) - .* - outlook/mi';
$str = 'Kalender - user1@firma.de - outlook
Kalender - user1@company.com - outlook
Kalender - user2@company.com - outlook
Kalender - user3@company.com - outlook
inbox - user1@company.com - outlook
inbox - user2@company.com - outlook
inbox - user3@company.com - outlook
sent - user1@company.com - outlook
sent - user2@company.com - outlook
sent - user3@company.com - outlook
waiting - user1@company.com - outlook
waiting - user2@company.com - outlook
waiting - user3@company.com - outlook';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);