use strict;
my $str = 'Kalender - user1@firma.de - outlook
Kalender - user1@company.com - outlook
Kalender - user2@company.com - outlook
Kalender - user3@company.com - outlook
inbox - user1@company.com - outlook
inbox - user2@company.com - outlook
inbox - user3@company.com - outlook
sent - user1@company.com - outlook
sent - user2@company.com - outlook
sent - user3@company.com - outlook
waiting - user1@company.com - outlook
waiting - user2@company.com - outlook
waiting - user3@company.com - outlook';
my $regex = qr/(?<!^kalender) - .* - outlook/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}