# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\\/BLOG\\/Tags)(\\/.+)\b/\/tag\L$2/gm;t' <<< "/BLOG/Tags/Finereader-server/"