using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/BLOG\/Tags)(\/.+)\b";
string substitution = @"/tag\L$2";
string input = @"/BLOG/Tags/Finereader-server/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}