const regex = /^(\/BLOG\/Tags)(\/.+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/BLOG\\\/Tags)(\\\/.+)\\b', 'gm')
const str = `/BLOG/Tags/Finereader-server/`;
const subst = `/tag\L$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);