use strict;
my $str = '/BLOG/Tags/Finereader-server/';
my $regex = qr/^(\/BLOG\/Tags)(\/.+)\b/mp;
my $subst = '/tag\\L$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";