# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(.{25})(\1).*/$2/g;t' <<< "///////////////////// some text /////////////////////
(.*)(.{25})(\1).*
"