import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(.{25})(\\1).*";
final String string = "///////////////////// some text /////////////////////\n\n\n"
+ "(.*)(.{25})(\\1).* \n\n\n\n\n\n\n\n";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}