import re
regex = re.compile(r"(.*)(.{25})(\1).*")
test_str = ("///////////////////// some text /////////////////////\n\n\n"
"(.*)(.{25})(\\1).* \n\n\n\n\n\n\n\n")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)