use strict;
my $str = '///////////////////// some text /////////////////////
(.*)(.{25})(\\1).*
';
my $regex = qr/(.*)(.{25})(\1).*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";