import Foundation
let pattern = #"(.*)(.{25})(\1).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
///////////////////// some text /////////////////////
(.*)(.{25})(\1).*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)