# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(https?:\/\/)www\.(?!ithome|pan)(.*\/.*)/$1$2/gm;t' <<< "!^(https?://)www\.(.*/.*)!$1$2!gm
!^(https?://)www\.(?!ithome|pan)(.*/.*)!$1$2!gm
(?!ithome|pan) 👈Please support the RegExp of exclusion
https://www.ithome.com/html/win10/321690.htm
https://www.ihome.com/html/win10/321690.htm
https://www.pan.ddd.com/html/win10/321690.htm
https://www.regex101.com/
https://www.ome.com/html/win10/321690.htm"