$re = '`^(https?://)www\.(?!ithome|pan)(.*/.*)`m';
$str = '!^(https?://)www\\.(.*/.*)!$1$2!gm
!^(https?://)www\\.(?!ithome|pan)(.*/.*)!$1$2!gm
(?!ithome|pan) 👈Please support the RegExp of exclusion
https://www.ithome.com/html/win10/321690.htm
https://www.ihome.com/html/win10/321690.htm
https://www.pan.ddd.com/html/win10/321690.htm
https://www.regex101.com/
https://www.ome.com/html/win10/321690.htm';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;