const regex = new RegExp('^(https?://)www\\.(?!ithome|pan)(.*/.*)', 'gm')
const str = `!^(https?://)www\\.(.*/.*)!\$1\$2!gm
!^(https?://)www\\.(?!ithome|pan)(.*/.*)!\$1\$2!gm
(?!ithome|pan) 👈Please support the RegExp of exclusion
https://www.ithome.com/html/win10/321690.htm
https://www.ihome.com/html/win10/321690.htm
https://www.pan.ddd.com/html/win10/321690.htm
https://www.regex101.com/
https://www.ome.com/html/win10/321690.htm`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);