import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?://)www\\.(?!ithome|pan)(.*/.*)";
final String string = "!^(https?://)www\\.(.*/.*)!$1$2!gm\n"
+ "!^(https?://)www\\.(?!ithome|pan)(.*/.*)!$1$2!gm\n"
+ "(?!ithome|pan) 👈Please support the RegExp of exclusion\n"
+ "https://www.ithome.com/html/win10/321690.htm\n"
+ "https://www.ihome.com/html/win10/321690.htm\n"
+ "https://www.pan.ddd.com/html/win10/321690.htm\n"
+ "https://www.regex101.com/\n"
+ "https://www.ome.com/html/win10/321690.htm";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}