import Foundation
let pattern = #"^(https?://)www\.(?!ithome|pan)(.*/.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!^(https?://)www\.(.*/.*)!$1$2!gm
!^(https?://)www\.(?!ithome|pan)(.*/.*)!$1$2!gm
(?!ithome|pan) 👈Please support the RegExp of exclusion
https://www.ithome.com/html/win10/321690.htm
https://www.ihome.com/html/win10/321690.htm
https://www.pan.ddd.com/html/win10/321690.htm
https://www.regex101.com/
https://www.ome.com/html/win10/321690.htm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)