# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?://)www\.(?!ithome|pan)(.*/.*)"
test_str = ("!^(https?://)www\\.(.*/.*)!$1$2!gm\n"
"!^(https?://)www\\.(?!ithome|pan)(.*/.*)!$1$2!gm\n"
"(?!ithome|pan) 👈Please support the RegExp of exclusion\n"
"https://www.ithome.com/html/win10/321690.htm\n"
"https://www.ihome.com/html/win10/321690.htm\n"
"https://www.pan.ddd.com/html/win10/321690.htm\n"
"https://www.regex101.com/\n"
"https://www.ome.com/html/win10/321690.htm")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.