#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@(?:[a-z]-?)+(?<!-)\w+"
Local $sString = "good" & @CRLF & _
"@good-1" & @CRLF & _
"@rizalibnu" & @CRLF & _
"@rizal-ibnu" & @CRLF & _
"@rizal_ibnu" & @CRLF & _
"@rizal ibnu" & @CRLF & _
"rizalibnu" & @CRLF & _
"@Rizalibnu" & @CRLF & _
"@muhamad-rizal-ibnu-abdulah" & @CRLF & _
"oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")