using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(?:[a-z]-?)+(?<!-)\w+";
string input = @"good
@good-1
@rizalibnu
@rizal-ibnu
@rizal_ibnu
@rizal ibnu
rizalibnu
@Rizalibnu
@muhamad-rizal-ibnu-abdulah
oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}