$re = '/@(?:[a-z]-?)+(?<!-)\w+/';
$str = 'good
@good-1
@rizalibnu
@rizal-ibnu
@rizal_ibnu
@rizal ibnu
rizalibnu
@Rizalibnu
@muhamad-rizal-ibnu-abdulah
oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);