re = /@(?:[a-z]-?)+(?<!-)\w+/
str = 'good
@good-1
@rizalibnu
@rizal-ibnu
@rizal_ibnu
@rizal ibnu
rizalibnu
@Rizalibnu
@muhamad-rizal-ibnu-abdulah
oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end