import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(?:[a-z]-?)+(?<!-)\\w+";
final String string = "good\n"
+ "@good-1\n"
+ "@rizalibnu\n"
+ "@rizal-ibnu\n"
+ "@rizal_ibnu\n"
+ "@rizal ibnu\n"
+ "rizalibnu\n"
+ "@Rizalibnu\n"
+ "@muhamad-rizal-ibnu-abdulah\n"
+ "oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}