#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-(.*)\((.*)\)"
Local $sString = "-Quarter(18548748)" & @CRLF & _
"-Quarter(45786)" & @CRLF & _
"-Quarter(8378)" & @CRLF & _
"-Quarter(737863)" & @CRLF & _
"-OUTSOLE 01(87678)" & @CRLF & _
"-OUTSOLE 01(75786)" & @CRLF & _
"-OUTSOLE 01(434+67)" & @CRLF & _
"-OUTSOLE 01(786378+)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")